Как в скд сделать расшифровку

В сформированном отчете 1С на СКД существует возможность двойным кликом мыши на ячейку вызвать всплывающее окно расшифровки с набором определенных действий. К таким действиям относятся:

  • раскрытие группировки;
  • открытие документа или элемента справочника;
  • открыть другой отчет;
  • открыть обороты или анализ счета, если речь идет о программе, где ведется бухгалтерский учет;
  • упорядочивание;
  • ограничить действия пользователя;
  • добавить собственное произвольное действие;
  • компоновать состав меню в зависимости от данных в ячейках.

Наибольший интерес вызывает открытие по расшифровке в 1С другого отчета 1С с параметром, содержащемся в выбранной ячейке. Но и другие действия будут доступны.

Начнем с того, что нужно вызвать событие обработки расшифровки в свойствах управляемой формы СКД. Сейчас те, кто работал на 7-ке, возможно, ужаснутся, так как лично для меня это было жутко нелогично. В 8-ке все гораздо прозаичней. Нужно создать основную форму, затем перейти на нее и открыть свойства реквизита «Результат»:

Обращу внимание, что реквизит «Результат» появляется только после того, как создана «ОсновнаяСхемаКомпоновкиДанных», и при создании формы установлены следующие флажки:

Я сразу приведу текст процедур и функций для организации расшифровок на СКД в 1С, а пояснения буду давать в комментариях. Читать на сайте код достаточно сложно, поэтому Вы можете скачать этот отчет и читать код в конфигураторе 1С 8.3. А результат работы отчета можно увидеть под этим кодом:

//Здесь заполняем колонки, на которые должна реагировать расшифровка.
//В данном варианте отчета поля д.б. ссылками
МРасшифровываемых = Новый Массив ( ) ;
МРасшифровываемых . Добавить ( «Контрагент» ) ;
МРасшифровываемых . Добавить ( «Номенклатура» ) ;

//Полученное значение
РасшифрЗначение = ПолучитьРасшифровкуНаСервере (
Расшифровка , МРасшифровываемых ) ;

Если РасшифрЗначение = Неопределено Тогда Возврат ; КонецЕсли ;
СтандартнаяОбработка = Ложь ;

// Прописываем доступные действия. Если какое-то действие не указать,
//оно не будет доступно пользователю

ОбрРасшифровки = Новый
ОбработкаРасшифровкиКомпоновкиДанных (
ДанныеРасшифровки ,
Новый ИсточникДоступныхНастроекКомпоновкиДанных ( Отчет ) ) ;

ВыпДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных . Нет ;
ПараметрВыполненногоДействия = Неопределено ;
ДоступДействия = Новый Массив ;
ДоступДействия . Добавить (
ДействиеОбработкиРасшифровкиКомпоновкиДанных . ОткрытьЗначение ) ;
ДоступДействия . Добавить (
ДействиеОбработкиРасшифровкиКомпоновкиДанных . Отфильтровать ) ;
ДоступДействия . Добавить (
ДействиеОбработкиРасшифровкиКомпоновкиДанных . Оформить ) ;
ДоступДействия . Добавить (
ДействиеОбработкиРасшифровкиКомпоновкиДанных . Расшифровать ) ;
ДоступДействия . Добавить (
ДействиеОбработкиРасшифровкиКомпоновкиДанных . Сгруппировать ) ;
ДоступДействия . Добавить (
ДействиеОбработкиРасшифровкиКомпоновкиДанных . Упорядочить ) ;
//Создаем собственные действия

ДопПункты = Новый СписокЗначений ;
ОбщСтрока = «Открыть отчет Расчеты с поставщиками «
+ «» «» + Строка ( ТипЗнч ( РасшифрЗначение ) )
+ » = « + РасшифрЗначение + «» «» ;

ДопПункты . Добавить ( 1 , ОбщСтрока + » за 1 мес.» ) ;
ДопПункты . Добавить ( 3 , ОбщСтрока + » за 3 мес.» ) ;
ДопПункты . Добавить ( 6 , ОбщСтрока + » за 6 мес» ) ;
ДопПункты . Добавить ( 12 , ОбщСтрока + » за 12 мес.» ) ;

Читайте также:  Где находится архив в инстаграме на телефоне

//Меню
ОбрРасшифровки . ВыбратьДействие (
Расшифровка ,
ВыпДействие ,
ПараметрВыполненногоДействия ,
ДоступДействия ,
ДопПункты ) ;

ЕслиВыпДействие
= ДействиеОбработкиРасшифровкиКомпоновкиДанных . Нет Тогда
ИначеЕсли ВыпДействие
= ДействиеОбработкиРасшифровкиКомпоновкиДанных . ОткрытьЗначение Тогда
ОткрытьЗначение ( ПараметрВыполненногоДействия ) ;
ИначеЕсли ТипЗнч ( ВыпДействие ) = Тип ( «Число» ) Тогда

Форм2 = ПолучитьФорму (
«Отчет.РасчетыСПоставщиками.Форма» ,
,
,
РасшифрЗначение ) ; //Форма Расшифровки.

КомпоновщНастр = ЭтаФорма . Отчет . КомпоновщикНастроек ;
КомпоновщНастр2 = Форм2 . Отчет . КомпоновщикНастроек ;

//Здесь устанавливаем настройки открываемого отчета
УстановитьЗначениеОтбораКомпоновщикаНастроекПоОбразцу (
КомпоновщНастр ,
КомпоновщНастр2 ,
«Контрагент» ) ;

УстановитьЗначениеОтбораКомпоновщикаНастроек ( КомпоновщНастр2 ,
Строка ( ТипЗнч ( РасшифрЗначение ) ) ,
РасшифрЗначение ,
ВидСравненияКомпоновкиДанных . Равно ) ;

ДатаКонца = ПолучитьЗначениеПераметраКомпоновщикаНастроек (
ЭтаФорма . Отчет . КомпоновщикНастроек ,
«ДатаКонца» ) ;

ПериодОтчета = Новый СтандартныйПериод (
ДобавитьМесяц ( ДатаКонца , — ВыпДействие ) ,
ДатаКонца ) ;

УстановитьЗначениеПераметраКомпоновщикаНастроек (
КомпоновщНастр2 ,
«Период» ,
ПериодОтчета ) ;

//Здесь открываем новый отчет
СтрВозврата = ОбработатьРасшифровкуНаСервере (
Форм2 . Отчет , «ОтчетОбъект.РасчетыСПоставщиками» ,
Форм2 . ОтчетТабличныйДокумент ,
Форм2 . НавигационнаяСсылка ,
Форм2 . УникальныйИдентификатор ) ;

Форм2 . ОтчетТабличныйДокумент = СтрВозврата . Результат ;
Форм2 . НавигационнаяСсылка = СтрВозврата . ДанныеРасшифровки ;
Форм2 . Открыть ( ) ;

&НаСервере
Функция ПолучитьРасшифровкуНаСервере (
Расшифровка ,
МассивИменРасшифровки ,
ЭтоГруппа = Ложь )

Данные = ПолучитьИзВременногоХранилища ( ДанныеРасшифровки ) ;
Поля = Данные . Элементы . Получить ( Расшифровка ) . ПолучитьПоля ( ) ;
Для Каждого ИмяРасшифровки Из МассивИменРасшифровки Цикл
ПолеНоменкл = Поля . Найти ( ИмяРасшифровки ) ;
Если Не ПолеНоменкл = Неопределено Тогда Прервать ; КонецЕсли ;
КонецЦикла ;
Возврат ПолеНоменкл . Значение ;
КонецФункции

&НаКлиенте
Процедура УстановитьЗначениеОтбораКомпоновщикаНастроек (
КомпоновщНастр2 ,
ИмяОтбора ,
Значение ,
ВидСравнения ,
Использование = Истина )

ПолеЭлементаОтбора =
КомпоновщНастр2 . Настройки . Отбор . ДоступныеПоляОтбора . Элементы . Найти ( ИмяОтбора ) . Поле ;

ИДЭлмОтбора = «» ;
Для Каждого Элемент Из КомпоновщНастр2 . Настройки . Отбор . Элементы Цикл
Если Элемент . ЛевоеЗначение = ПолеЭлементаОтбора Тогда
ИДЭлмОтбора = Элемент . ИдентификаторПользовательскойНастройки ;
Прервать ;
КонецЕсли ;
КонецЦикла ;

Коллекция2 = КомпоновщНастр2 . ПользовательскиеНастройки . Элементы ;

Если ИДЭлмОтбора = «» Тогда //Нет среди стандартных настроек
Для Каждого Элемент Из Коллекция2 Цикл //Ищем….
Если ТипЗнч ( Элемент ) = Тип ( «ОтборКомпоновкиДанных» ) Тогда
ПолеОтбора = Новый ПолеКомпоновкиДанных ( ИмяОтбора ) ;
ОтборНайден = Ложь ;
Для Каждого ЭлемОтбора Из Элемент . Элементы Цикл
Если ЭлемОтбора . ЛевоеЗначение = ПолеОтбора Тогда
ОтборНайден = Истина ; Прервать ; КонецЕсли ;
КонецЦикла ;
Если Не ОтборНайден Тогда
ЭлемОтбора = Элемент . Элементы . Добавить ( Тип ( «ЭлемОтбораКомпоновкиДанных» ) ) ;
Элемент . Элементы [ 0 ] . ЛевоеЗначение = ПолеОтбора ;
ЭлемОтбора . ЛевоеЗначение = Новый ПолеКомпоновкиДанных ( ИмяОтбора ) ;
КонецЕсли ;
Прервать ;
КонецЕсли ;
КонецЦикла ;
Иначе
ЭлемОтбора = Коллекция2 . Найти ( ИДЭлмОтбора ) ;
КонецЕсли ;

ЭлемОтбора . ПравоеЗначение = Значение ;
ЭлемОтбора . Использование = Использование ;
ЭлемОтбора . ВидСравнения = ВидСравнения ;

&НаКлиенте
Процедура УстановитьЗначениеОтбораКомпоновщикаНастроекПоОбразцу ( КомпоновщНастр , КомпоновщНастр2 , ИмяОтбора )
Отбор = КомпоновщНастр . Настройки . Отбор ;
Для Каждого Элемент Из Отбор . Элементы Цикл
ЭлемОтбора = Элемент ;
Прервать ;
КонецЦикла ;
УстановитьЗначениеОтбораКомпоновщикаНастроек ( КомпоновщНастр2 , ИмяОтбора , ЭлемОтбора . ПравоеЗначение , ЭлемОтбора . ВидСравнения , ЭлемОтбора . Использование ) ;
КонецПроцедуры

&НаСервере
Функция ОбработатьРасшифровкуНаСервере ( Знач ОтчетZ , СтрТипаОтчета , Знач РезультатZ , Знач ДанныеРасшифровкиZ , Знач ИДФормы )
ОтчетОбъект = ДанныеФормыВЗначение ( ОтчетZ , Тип ( СтрТипаОтчета ) ) ;
РезультатZ . Очистить ( ) ;
ОтчетОбъект . СкомпоноватьРезультат ( РезультатZ , ДанныеРасшифровкиZ ) ; //Формируем
АдресДанныхРасшифровки = ПоместитьВоВременноеХранилище ( ДанныеРасшифровкиZ , ИДФормы ) ;
Возврат Новый Структура ( «Результат,ДанныеРасшифровки» , РезультатZ , АдресДанныхРасшифровки ) ;
КонецФункции

Результат проделанной работы:

Это наш простенький отчет с уже открытой расшифровкой.

Читайте также:  Буквы из бумаги своими руками схемы шаблоны

После выбора нужной позиции откроется отчет «Ведомость расчетов с поставщиками»:

У меня данных в этом отчете нет, но видно, что параметры формирования передались правильно.

Если Вы начинаете изучать 1С программирование, рекомендуем наш бесплатный курс (не забудьте подписаться на YouTube — регулярно выходят новые видео):

В отчетах, построенных на СКД (системе компоновки данных), существует возможность расшифровать результат отчета путем открытия дополнительного отчета с более глубокой детализацией данных.

Типовой функционал позволяет открыть из отчета соответствующие справочники, документы-регистраторы и другую информацию. Наведя на ячейку курсором мышки, можно увидеть, возможна ли для не расшифровка. Если дополнительные действия по расшифровке доступны, то иконка курсора изменит свой вид.


Рис.1 Изменение курсора мыши при наведении на выбранную ячейку отчета

Для того чтобы посмотреть какая расшифровка возможна для нужной ячейки отчета, необходимо щелкнуть по ячейке два раза мышкой.


Рис.2 Список возможных действий при нажатии на ячейку с данными

По умолчанию открывается стандартная расшифровка, которая является общей для большинства отчетов конфигурации. Например, если щелкнуть на номенклатуру и в открывшемся окне навести курсор на «Открыть», то можно открыть необходимый элемент справочника номенклатуры, серии или характеристики.


Рис.3 Открытие справочников из отчета на СКД

Также можно отфильтровать, упорядочить, сгруппировать данные или оформить их.


Рис.4 Дополнительные механизмы работы с данными в отчете, фильтрация

Наряду со стандартными действиями есть возможность добавить собственные, а можно и полностью переоопределить стандартную расшифровку.

Расшифровка другим отчетом

Важным моментом для пользователей является возможность расшифровки данных отчета другим отчетом. Например, пользователь выводит отчет с номенклатурой, которую заказали клиенты. С помощью расшифровки другим отчетом пользователь может увидеть, какое количество этого товара было отгружено, например, за последний месяц.

Для начала создадим через Конфигуратор отчет, в котором с помощью конструктора построим основную схему компоновки данных.


Рис.5 Создание схемы компоновки данных из конфигуратора с помощью конструктора макета

Схема будет храниться в макете. Создаем выборку данных, настраиваем наборы данных и задаем другие настройки, необходимые для корректной работы отчета.


Рис.6 Создание отчета на СКД и настройка получения данных

После добавления макета нужно добавить основную форму отчета.


Рис.7 Добавление основной формы отчета

Для реквизита формы «Результат» необходимо заполнить действие «Обработка Расшифровки».


Рис. 8 Добавление обработки расшифровки для результата

В модуле формы мы и будем прописывать открытие нашего меню расшифровки.

Читайте также:  Как войти в плей маркет без аккаунта


Рис.9 Модуль формы отчета для задания дополнительных действий с отчетом и его расшифровки

Для начала в модуле формы отчета в процедуре РезультатОбработкаРасшифровки описываем получение полей, для которых будет выводиться расшифровка:

В коде запрещаем открытие стандартной расшифровки:

Выводим в расшифровку собственные действия:


Рис.10 Добавление своих пунктов в отчет на СКД и расшифровка их, открытие дополнительного меню

После описания собственного меню расшифровки, определения полей, для которых будет действовать расшифровка, необходимо передать параметры в новый открываемый отчет для его формирования.


Рис.11 Расшифровка отчета другим отчетом на СКД

Для расшифровки на сервере используем следующую функцию:

Созданные на СКД отчеты предоставляют пользователям 1С широчайшие возможности по гибкой настройке выводимых данных. В программе присутствует типовой функционал по расшифровке данных, а с помощью программирования можно создавать дополнительные варианты любых действий.

Продолжая свой цикл заметок про СКД, сегодня я хотел бы поподробнее остановиться на расшифровке.

В СКД расшифровка представляет собой всплывающее меню (по двойному клику на ячейке), содержащие доступные пользователю действия, такие как открытие ссылки на элемент, упорядочивание, группировка, оформление и пр. Здесь я приведу примеры решения наиболее распространенных задач, связанных с расшифровкой, таких как:
1. Ограничение доступных действий;
2. Добавление в меню своего произвольного действия;
3. Добавление в меню различных действий, в зависимости от ячейки, для которой выполняется расшифровка.

Вся работа с расшифровкой, выполняется в событии ОбработкаРасшифровки. Что бы получить доступ к этому событию, необходимо сначала сгенерировать основную форму отчета. Затем ПолеТабличногоДокумента > Свойства > События.

Итак, задача №1. Постановка: Необходимо доступные действия для пользователя ограничить только: открытием элемента, упорядочиванием и оформлением.
Решение:
Код 1C v 8.х

Задача №2. Постановка: Необходимо добавить в меню свое действие, открывающее основную форму элемента, содержащегося в ячейке, для которой выполняется расшифровка.
Решение:
Код 1C v 8.х
В процедуре ВыполнитьДействие1(Расшифровка) получаем ПараметрРасшифровки для выбранной ячейки и открывает основную форму:
Код 1C v 8.х

Задача №3. Постановка: Необходимо в зависимости от колонки, для которой выполняется расшифровка, добавлять свои действия: для «Поле1» – «Действие1», для «Поле2» – «Действие2».
Решение:
Код 1C v 8.х
Как видите, ничего сложного здесь нет!
Источник
При использовании в типовой конфигурации:
Код 1C v 8.х

Ссылка на основную публикацию
Adblock detector