Как в экселе посчитать выборочно сумму столбца

Табличный процессор Excel – отличное решение для обработки разного рода данных. С его помощью можно быстро производить расчеты с регулярно меняющимися данными. Однако Excel достаточно сложная программа и поэтому многие пользователи даже не начинают ее изучать.

В данной статье мы расскажем о том, как посчитать сумму в Excel. Надеемся, что этот материал поможет вам познакомиться с Excel и научиться использовать его основные функции.

Как посчитать сумму столбца в Excel

Если вам необходимо посчитать сумму столбца в Excel, то это делается достаточно просто. Для этого вам понадобится кнопка «Авто сумма». Она находится на вкладке «Главная» (справа, в самом конце вкладки).

Также кнопка «Авто сумма» дублируется на вкладе «Формулы».

Для того чтобы посчитать сумму столбца, выделите этот столбец с помощью мышки и нажмите на кнопку «Авто сумма».

После выделения столбца с данными и нажатия на кнопку «Авто сумма» Excel автоматически сгенерирует формулу для подсчета суммы столбца и вставит ее в ячейку сразу под столбцом с данными.

Если такое расположение суммы столбца вам не подходит, то вы можете сами указать, где хотите расположить сумму. Для этого нужно выделить подходящую для суммы ячейку, нажать на кнопку «Автосумма», а потом выделить мышкой столбец с данными и нажать на клавишу Enter на клавиатуре.

В этом случае сумма столбца будет расположена не под столбцом с данными, а в выбранной вами ячейке таблицы.

Как посчитать сумму определенных ячеек в Excel

Если вам нужно посчитать сумму определенных ячеек в Excel, то это также можно сделать при помощи функции «Авто сумма». Для этого нужно выделить мышкой ячейку таблицы, в которую вы хотите поместить сумму, нажать на кнопку «Авто сумма» и выбрать нужные ячейки удерживая зажатой клавишу CTRL на клавиатуре. После того, как нужные ячейки выбраны, нажмите на клавишу Enter на клавиатуре, и в выбранной вами ячейке таблицы будет помещена сумма.

Кроме этого, вы можете вписать формулу для подсчета суммы определенных ячеек вручную. Для этого установите курсор там, где должна находится сумма, а потом введите формулу в формате: =СУММ(D3; D5; D7). Где вместо D3, D5 и D7 – адреса нужных вам ячеек. Обратите внимание, адреса ячеек вводятся через запятую, после последней ячейки запятая не нужна. После ввода формулы нажмите клавишу Eneter и в выбранной вами ячейке появится сумма.

Читайте также:  Завод самсунг в россии

Если формулу нужно отредактировать, например, вам нужно изменить адреса ячеек, то для этого нужно выделить ячейку с суммой и изменить формулу в строке для формул.

Как быстро посмотреть сумму в Excel

Если вам нужно быстро посмотреть какая сумма получится если сложить определенные ячейки, и при этом вам не нужно выводить значение суммы в таблицу, то вы можете просто выделить ячейки и посмотреть вниз окна Excel. Там вы сможете найти информацию о сумме выделенных ячеек.

Также там будет указано количество выделенных ячеек и их среднее значение.

Эксель предназначен для работы с табличными данными и ведения расчетов с использованием разного уровня сложности формул. Посчитать сумму по столбцу или строке, сразу по нескольким областям значений – легкое задание, если знать, как правильно это сделать.

Способ 1 – Автосуммирование

  1. Курсор установить в месте, в котором надо вывести значение подсчетов.
  2. На вкладке «Главная» нажать значок Автосуммы или воспользоваться сочетанием клавиш Alt и =.

  • Вокруг чисел, вписанных в столбце выше ячейки с общей суммой, появляется мигающий пунктир. Он показывает, какие области данных будут суммироваться и нажать Enter.
  • Если требуется просуммировать сразу несколько столбцов или строк, то:

    1. Выделить ячейки, в которых будет отражена сумма по каждому из столбцов.
    2. Нажать символ Автосуммы.
    3. Enter. Итоги будут посчитаны сразу по двум столбцам.

    Если требуется найти сумму вместе с несколькими дополнительными ячейками:

    1. Выделить область для вывода итогов.
    2. Нажать на иконку Автосуммы.
    3. Диапазон автоматически определится в составе всех вышерасположенных ячеек.
    4. Зажать Ctrl и выделить дополнительные области и нажать Enter.

    Способ 2. Ручной ввод формулы

    Удобен при необходимости подсчитать итог сложения значений, хаотично расположенных по отношению друг к другу. Создаем формулу пошагово:

    1. Курсор поставить на ячейку с будущим итогом.
    2. Ввести =. С равенства начинается любая формула в Excel.
    3. Левой кнопкой мыши щелкать по нужным для суммирования ячейкам, ставя между ними + и Enter.

    Способ 3. Наглядное суммирование

    Особенность этого способа в том, что итог не выводится в отдельную ячейку, нет необходимости использовать формулы. Конечный результат будет виден в нижнем правом углу листа документа при выделенном диапазоне ячеек. Как только выделение снимается, сумма исчезает. Поэтапные действия:

    1. Мышкой выделить необходимый столбец или строку.
    2. Посмотреть на результат.

    Простые логические функции такие как ЕСЛИ обычно предназначены для работы с одним столбцом или одной ячейкой. Excel также предлагает несколько других логических функций служащих для агрегирования данных. Например, функция СУММЕСЛИ для выборочного суммирования диапазона значений по условию.

    Читайте также:  Как бесплатно пополнить киви кошелек

    Примеры формулы для суммы диапазонов с условием отбора в Excel

    Ниже на рисунке представлен в таблице список счетов вместе с состоянием по каждому счету в виде положительных или отрицательных чисел. Допустим нам необходимо посчитать сумму всех отрицательных чисел для расчета суммарного расхода по движению финансовых средств. Этот результат будет позже сравниваться вместе с сумой положительных чисел с целью верификации и вывода балансового сальдо. Узнаем одинаковые ли суммы доходов и расходов – сойдется ли у нас дебит с кредитом. Для суммирования числовых значений по условию в Excel применяется логическая функция =СУММЕСЛИ():

    Функция СУММЕСЛИ анализирует каждое значение ячейки в диапазоне B2:B12 и проверяет соответствует ли оно заданному условию (указанному во втором аргументе функции). Если значение меньше чем 0, тогда условие выполнено и данное число учитывается в общей итоговой сумме. Числовые значения больше или равно нулю игнорируются функцией. Проигнорированы также текстовые значения и пустые ячейки.

    В приведенном примере сначала проверяется значения ячейки B2 и так как оно больше чем 0 – будет проигнорировано. Далее проверяется ячейка B3. В ней числовое значение меньше нуля, значит условие выполнено, поэтому оно добавляется к общей сумме. Данный процесс повторяется для каждой ячейки. В результате его выполнения суммированы значения ячеек B3, B6, B7, B8 и B10, а остальные ячейки не учитываются в итоговой сумме.

    Обратите внимание что ниже результата суммирования отрицательных чисел находится формула суммирования положительных чисел. Единственное отличие между ними — это обратный оператор сравнения во втором аргументе где указывается условие для суммирования – вместо строки " 0" (больше чем ноль). Теперь мы можем убедиться в том, что дебет с кредитом сходится балансовое сальдо будет равно нулю если сложить арифметически в ячейке B16 формулой =B15+B14.

    Пример логического выражения в формуле для суммы с условием

    Другой пример, когда нам нужно отдельно суммировать цены на группы товаров стоимости до 1000 и отдельно со стоимостью больше 1000. В таком случае одного оператора сравнения нам недостаточно ( =1000) иначе мы просуммируем сумму ровно в 1000 – 2 раза, что приведет к ошибочным итоговым результатам:

    Это очень распространенная ошибка пользователей Excel при работе с логическими функциями!

    Внимание! В первом примере нулевые значения нам необязательно было учитывать, так как на балансовое сальдо это никак не повлияло бы, но во втором случаи нужно составлять критерий условия суммирования иначе, чтобы не допустить ошибочных просчетов.

    Читайте также:  В одноранговой сети все компьютеры равноправны

    Второй аргумент функции СУММЕСЛИ, то есть условие, которое должно быть выполнено, записывается между двойными кавычками. В данном примере используется символ сравнения – «меньше» ( ) меньше ( ), больше или равно (>=), меньше или равно ( Таблица правил составления критериев условий:

    Чтобы создать условие Примените правило Пример
    Значение равно заданному числу или ячейке с данным адресом. Не используйте знак равенства и двойных кавычек. =СУММЕСЛИ(B1:B10;3)
    Значение равно текстовой строке. Не используйте знак равенства, но используйте двойные кавычки по краям. =СУММЕСЛИ(B1:B10;"Клиент5")
    Значение отличается от заданного числа. Поместите оператор и число в двойные кавычки. =СУММЕСЛИ(B1:B10;">=50")
    Значение отличается от текстовой строки. Поместите оператор и число в двойные кавычки. =СУММЕСЛИ(B1:B10;"<>выплата")
    Значение отличается от ячейки по указанному адресу или от результата вычисления формулы. Поместите оператор сравнения в двойные кавычки и соедините его символом амперсант (&) вместе со ссылкой на ячейку или с формулой. =СУММЕСЛИ(A1:A10;" "&СЕГОДНЯ())
    Значение содержит фрагмент строки Используйте операторы многозначных символов и поместите их в двойные кавычки =СУММЕСЛИ(A1:A10;"*кг*";B1:B10)

    Во втором аргументе критериев условий можно использовать разные функции и формулы. Ниже на рисунке изображен список дат и присвоенных им значений. Важно отметить что сегодня на момент написания статьи дата – «03.11.2018». Чтобы суммировать числовые значения только по сегодняшней дате используйте формулу:

    Чтобы суммировать только значения от сегодняшнего дня включительно и до конца периода времени воспользуйтесь оператором «больше или равно» (>=) вместе с соответственной функцией =СЕГОДНЯ(). Формула c операторам (>=):

    ="&СЕГОДНЯ();B2:B10)/B11′ >

    Суммирование по неточному совпадению в условии критерия отбора

    Во втором логическом аргументе критериев условий функции СУММЕСЛИ можно применять многозначные символы – (?)и(*) для составления относительных неточных запросов. Знак вопроса (?) – следует читать как любой символ, а звездочка (*) – это строка из любого количества любых символов или пустая строка. Например, нам необходимо просуммировать только защитные краски-лаки с кодом 3 английские буквы в начале наименования:

    Суммируются все значения ячеек в диапазоне B2:B16 в соответствии со значениями в ячейках диапазона A2:A16, в которых после третьего символа фрагмент строки «-защита».

    Таким образом удалось суммировать только определенную группу товаров в общем списке отчета по складу. Данный фрагмент наименования товара должен встречаться в определенном месте – 3 символа от начала строки. Нет необходимости использовать сложные формулы с функцией =ЛЕВСИМВ() и т.д. Достаточно лишь воспользоваться операторами многозначных символов чтобы сформулировать простой и лаконичный запрос к базе данных с минимальными нагрузками на системные ресурсы.

    Ссылка на основную публикацию
    Adblock detector